main.spec 797 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # -*- mode: python ; coding: utf-8 -*-
  2. a = Analysis(
  3. ['main.py'],
  4. pathex=[],
  5. binaries=[],
  6. datas=[],
  7. hiddenimports=[],
  8. hookspath=[],
  9. hooksconfig={},
  10. runtime_hooks=[],
  11. excludes=[],
  12. noarchive=False,
  13. )
  14. pyz = PYZ(a.pure)
  15. exe = EXE(
  16. pyz,
  17. a.scripts,
  18. [],
  19. exclude_binaries=True,
  20. name='g4f',
  21. debug=False,
  22. bootloader_ignore_signals=False,
  23. strip=False,
  24. upx=True,
  25. console=True,
  26. disable_windowed_traceback=False,
  27. argv_emulation=False,
  28. target_arch=None,
  29. codesign_identity=None,
  30. entitlements_file=None,
  31. icon='icon.ico',
  32. )
  33. coll = COLLECT(
  34. exe,
  35. a.binaries,
  36. Tree('//host.lan/Data/g4f/gui/client', prefix='client'),
  37. a.datas,
  38. strip=False,
  39. upx=True,
  40. upx_exclude=[],
  41. name='g4f',
  42. )