default.nix 579 B

12345678910111213141516171819202122232425
  1. { pkgs ? import <nixpkgs> { } }: with pkgs;
  2. mkShell.override { stdenv = gcc13Stdenv; } {
  3. packages = [
  4. ccache
  5. cmake
  6. libxcrypt
  7. ninja
  8. pkg-config
  9. python3
  10. qt6.qtbase
  11. qt6.qtbase.dev
  12. qt6.qtmultimedia
  13. qt6.qttools
  14. qt6.qtwayland
  15. qt6.qtwayland.dev
  16. ];
  17. shellHook = ''
  18. # NOTE: This is required to make it find the wayland platform plugin installed
  19. # above, but should probably be fixed upstream.
  20. export QT_PLUGIN_PATH="$QT_PLUGIN_PATH:${qt6.qtwayland}/lib/qt-6/plugins"
  21. export QT_QPA_PLATFORM="wayland;xcb"
  22. '';
  23. }