buildozer.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455
  1. [app]
  2. # (str) Title of your application
  3. title = g4f
  4. # (str) Package name
  5. package.name = g4a
  6. # (str) Package domain (needed for android/ios packaging)
  7. package.domain = org.g4f
  8. # (str) Source code where the main.py live
  9. source.dir = .
  10. # (list) Source files to include (let empty to include all the files)
  11. #source.include_exts = py,png,jpg,kv,atlas,html,css,js,png
  12. # (list) List of inclusions using pattern matching
  13. source.include_patterns = main.py
  14. # (list) Source files to exclude (let empty to not exclude anything)
  15. #source.exclude_exts = spec
  16. # (list) List of directory to exclude (let empty to not exclude anything)
  17. source.exclude_dirs = etc, docker, docs, .github
  18. # (list) List of exclusions using pattern matching
  19. # Do not prefix with './'
  20. #source.exclude_patterns = license,images/*/*.jpg
  21. # (str) Application versioning (method 1)
  22. version = 0.1
  23. # (str) Application versioning (method 2)
  24. # version.regex = __version__ = ['"](.*)['"]
  25. # version.filename = %(source.dir)s/main.py
  26. # (list) Application requirements
  27. # comma separated e.g. requirements = sqlite3,kivy
  28. requirements = python3==3.11.7,kivy==2.3.0,aiohttp==3.9.3,aiosignal==1.3.1,attrs==23.2.0,beautifulsoup4==4.12.3,certifi==2024.2.2,charset-normalizer==3.3.2,docutils==0.20.1,frozenlist==1.4.1,idna==3.6,multidict==6.0.5,requests==2.31.0,soupsieve==2.5,Unidecode==1.3.8,urllib3==2.2.0,yarl==1.9.4,pywebview,pillow,platformdirs,python-for-android,plyer,/home/heiner/gpt4free2/,proxy_tools,bottle,typing_extensions,cryptography,brotli,android
  29. # (str) Custom source folders for requirements
  30. # Sets custom source for any requirements with recipes
  31. # requirements.source.g4f = /home/.../gpt4free
  32. # (str) Presplash of the application
  33. #presplash.filename = %(source.dir)s/data/presplash.png
  34. # (str) Icon of the application
  35. icon.filename = %(source.dir)s/g4f/gui/client/static/img/android-chrome-512x512.png
  36. # (list) Supported orientations
  37. # Valid options are: landscape, portrait, portrait-reverse or landscape-reverse
  38. orientation = portrait
  39. # (list) List of service to declare
  40. #services = NAME:ENTRYPOINT_TO_PY,NAME2:ENTRYPOINT2_TO_PY
  41. #
  42. # OSX Specific
  43. #
  44. #
  45. # author = © Copyright Info
  46. # change the major version of python used by the app
  47. osx.python_version = 3
  48. # Kivy version to use
  49. osx.kivy_version = 1.9.1
  50. #
  51. # Android specific
  52. #
  53. # (bool) Indicate if the application should be fullscreen or not
  54. fullscreen = 0
  55. # (string) Presplash background color (for android toolchain)
  56. # Supported formats are: #RRGGBB #AARRGGBB or one of the following names:
  57. # red, blue, green, black, white, gray, cyan, magenta, yellow, lightgray,
  58. # darkgray, grey, lightgrey, darkgrey, aqua, fuchsia, lime, maroon, navy,
  59. # olive, purple, silver, teal.
  60. #android.presplash_color = #FFFFFF
  61. # (string) Presplash animation using Lottie format.
  62. # see https://lottiefiles.com/ for examples and https://airbnb.design/lottie/
  63. # for general documentation.
  64. # Lottie files can be created using various tools, like Adobe After Effect or Synfig.
  65. #android.presplash_lottie = "path/to/lottie/file.json"
  66. # (str) Adaptive icon of the application (used if Android API level is 26+ at runtime)
  67. #icon.adaptive_foreground.filename = %(source.dir)s/data/icon_fg.png
  68. #icon.adaptive_background.filename = %(source.dir)s/data/icon_bg.png
  69. # (list) Permissions
  70. # (See https://python-for-android.readthedocs.io/en/latest/buildoptions/#build-options-1 for all the supported syntaxes and properties)
  71. android.permissions = android.permission.INTERNET, android.permission.CAMERA, android.permission.WRITE_EXTERNAL_STORAGE, android.permission.READ_EXTERNAL_STORAGE
  72. # (list) features (adds uses-feature -tags to manifest)
  73. #android.features = android.hardware.usb.host
  74. # (int) Target Android API, should be as high as possible.
  75. android.api = 21
  76. #31
  77. # (int) Minimum API your APK / AAB will support.
  78. android.minapi = 21
  79. # (int) Android SDK version to use
  80. #android.sdk = 23
  81. # File path exposed error
  82. # (str) Android NDK version to use
  83. #android.ndk = 23b
  84. # (int) Android NDK API to use. This is the minimum API your app will support, it should usually match android.minapi.
  85. #android.ndk_api = 21
  86. # (bool) Use --private data storage (True) or --dir public storage (False)
  87. #android.private_storage = True
  88. # (str) Android NDK directory (if empty, it will be automatically downloaded.)
  89. #android.ndk_path =
  90. # (str) Android SDK directory (if empty, it will be automatically downloaded.)
  91. #android.sdk_path =
  92. # (str) ANT directory (if empty, it will be automatically downloaded.)
  93. #android.ant_path =
  94. # (bool) If True, then skip trying to update the Android sdk
  95. # This can be useful to avoid excess Internet downloads or save time
  96. # when an update is due and you just want to test/build your package
  97. # android.skip_update = False
  98. # (bool) If True, then automatically accept SDK license
  99. # agreements. This is intended for automation only. If set to False,
  100. # the default, you will be shown the license when first running
  101. # buildozer.
  102. # android.accept_sdk_license = False
  103. # (str) Android entry point, default is ok for Kivy-based app
  104. #android.entrypoint = org.kivy.android.PythonActivity
  105. # (str) Full name including package path of the Java class that implements Android Activity
  106. # use that parameter together with android.entrypoint to set custom Java class instead of PythonActivity
  107. #android.activity_class_name = org.kivy.android.PythonActivity
  108. # (str) Extra xml to write directly inside the <manifest> element of AndroidManifest.xml
  109. # use that parameter to provide a filename from where to load your custom XML code
  110. #android.extra_manifest_xml = ./src/android/extra_manifest.xml
  111. # (str) Extra xml to write directly inside the <manifest><application> tag of AndroidManifest.xml
  112. # use that parameter to provide a filename from where to load your custom XML arguments:
  113. #android.extra_manifest_application_arguments = ./src/android/extra_manifest_application_arguments.xml
  114. # (str) Full name including package path of the Java class that implements Python Service
  115. # use that parameter to set custom Java class which extends PythonService
  116. #android.service_class_name = org.kivy.android.PythonService
  117. # (str) Android app theme, default is ok for Kivy-based app
  118. # android.apptheme = "@android:style/Theme.NoTitleBar"
  119. # (list) Pattern to whitelist for the whole project
  120. #android.whitelist =
  121. # (str) Path to a custom whitelist file
  122. #android.whitelist_src =
  123. # (str) Path to a custom blacklist file
  124. #android.blacklist_src =
  125. # (list) List of Java .jar files to add to the libs so that pyjnius can access
  126. # their classes. Don't add jars that you do not need, since extra jars can slow
  127. # down the build process. Allows wildcards matching, for example:
  128. # OUYA-ODK/libs/*.jar
  129. android.add_jars = /home/heiner/.local/lib/python3.10/site-packages/webview/lib/pywebview-android.jar
  130. # (list) List of Java files to add to the android project (can be java or a
  131. # directory containing the files)
  132. #android.add_src =
  133. # (list) Android AAR archives to add
  134. #android.add_aars =
  135. # (list) Put these files or directories in the apk assets directory.
  136. # Either form may be used, and assets need not be in 'source.include_exts'.
  137. # 1) android.add_assets = source_asset_relative_path
  138. # 2) android.add_assets = source_asset_path:destination_asset_relative_path
  139. #android.add_assets =
  140. # (list) Put these files or directories in the apk res directory.
  141. # The option may be used in three ways, the value may contain one or zero ':'
  142. # Some examples:
  143. # 1) A file to add to resources, legal resource names contain ['a-z','0-9','_']
  144. # android.add_resources = my_icons/all-inclusive.png:drawable/all_inclusive.png
  145. # 2) A directory, here 'legal_icons' must contain resources of one kind
  146. # android.add_resources = legal_icons:drawable
  147. # 3) A directory, here 'legal_resources' must contain one or more directories,
  148. # each of a resource kind: drawable, xml, etc...
  149. # android.add_resources = legal_resources
  150. #android.add_resources =
  151. # (list) Gradle dependencies to add
  152. #android.gradle_dependencies =
  153. # (bool) Enable AndroidX support. Enable when 'android.gradle_dependencies'
  154. # contains an 'androidx' package, or any package from Kotlin source.
  155. # android.enable_androidx requires android.api >= 28
  156. #android.enable_androidx = True
  157. # (list) add java compile options
  158. # this can for example be necessary when importing certain java libraries using the 'android.gradle_dependencies' option
  159. # see https://developer.android.com/studio/write/java8-support for further information
  160. # android.add_compile_options = "sourceCompatibility = 1.8", "targetCompatibility = 1.8"
  161. # (list) Gradle repositories to add {can be necessary for some android.gradle_dependencies}
  162. # please enclose in double quotes
  163. # e.g. android.gradle_repositories = "maven { url 'https://kotlin.bintray.com/ktor' }"
  164. #android.add_gradle_repositories =
  165. # (list) packaging options to add
  166. # see https://google.github.io/android-gradle-dsl/current/com.android.build.gradle.internal.dsl.PackagingOptions.html
  167. # can be necessary to solve conflicts in gradle_dependencies
  168. # please enclose in double quotes
  169. # e.g. android.add_packaging_options = "exclude 'META-INF/common.kotlin_module'", "exclude 'META-INF/*.kotlin_module'"
  170. #android.add_packaging_options =
  171. # (list) Java classes to add as activities to the manifest.
  172. #android.add_activities = com.example.ExampleActivity
  173. # (str) OUYA Console category. Should be one of GAME or APP
  174. # If you leave this blank, OUYA support will not be enabled
  175. #android.ouya.category = GAME
  176. # (str) Filename of OUYA Console icon. It must be a 732x412 png image.
  177. #android.ouya.icon.filename = %(source.dir)s/data/ouya_icon.png
  178. # (str) XML file to include as an intent filters in <activity> tag
  179. #android.manifest.intent_filters =
  180. # (list) Copy these files to src/main/res/xml/ (used for example with intent-filters)
  181. #android.res_xml = PATH_TO_FILE,
  182. # (str) launchMode to set for the main activity
  183. #android.manifest.launch_mode = standard
  184. # (str) screenOrientation to set for the main activity.
  185. # Valid values can be found at https://developer.android.com/guide/topics/manifest/activity-element
  186. #android.manifest.orientation = fullSensor
  187. # (list) Android additional libraries to copy into libs/armeabi
  188. #android.add_libs_armeabi = libs/android/*.so
  189. #android.add_libs_armeabi_v7a = libs/android-v7/*.so
  190. #android.add_libs_arm64_v8a = libs/android-v8/*.so
  191. #android.add_libs_x86 = libs/android-x86/*.so
  192. #android.add_libs_mips = libs/android-mips/*.so
  193. # (bool) Indicate whether the screen should stay on
  194. # Don't forget to add the WAKE_LOCK permission if you set this to True
  195. #android.wakelock = False
  196. # (list) Android application meta-data to set (key=value format)
  197. #android.meta_data =
  198. # (list) Android library project to add (will be added in the
  199. # project.properties automatically.)
  200. #android.library_references =
  201. # (list) Android shared libraries which will be added to AndroidManifest.xml using <uses-library> tag
  202. #android.uses_library =
  203. # (str) Android logcat filters to use
  204. #android.logcat_filters = *:S python:D
  205. # (bool) Android logcat only display log for activity's pid
  206. #android.logcat_pid_only = False
  207. # (str) Android additional adb arguments
  208. #android.adb_args = -H host.docker.internal
  209. # (bool) Copy library instead of making a libpymodules.so
  210. #android.copy_libs = 1
  211. # (list) The Android archs to build for, choices: armeabi-v7a, arm64-v8a, x86, x86_64
  212. # In past, was `android.arch` as we weren't supporting builds for multiple archs at the same time.
  213. android.archs = arm64-v8a
  214. #, armeabi-v7a
  215. # (int) overrides automatic versionCode computation (used in build.gradle)
  216. # this is not the same as app version and should only be edited if you know what you're doing
  217. # android.numeric_version = 1
  218. # (bool) enables Android auto backup feature (Android API >=23)
  219. android.allow_backup = True
  220. # (str) XML file for custom backup rules (see official auto backup documentation)
  221. # android.backup_rules =
  222. # (str) If you need to insert variables into your AndroidManifest.xml file,
  223. # you can do so with the manifestPlaceholders property.
  224. # This property takes a map of key-value pairs. (via a string)
  225. # Usage example : android.manifest_placeholders = [myCustomUrl:\"org.kivy.customurl\"]
  226. # android.manifest_placeholders = [:]
  227. # (bool) Skip byte compile for .py files
  228. # android.no-byte-compile-python = False
  229. # (str) The format used to package the app for release mode (aab or apk or aar).
  230. # android.release_artifact = aab
  231. # (str) The format used to package the app for debug mode (apk or aar).
  232. # android.debug_artifact = apk
  233. #
  234. # Python for android (p4a) specific
  235. #
  236. # (str) python-for-android URL to use for checkout
  237. #p4a.url =
  238. # (str) python-for-android fork to use in case if p4a.url is not specified, defaults to upstream (kivy)
  239. #p4a.fork = kivy
  240. # (str) python-for-android branch to use, defaults to master
  241. #p4a.branch = master
  242. # (str) python-for-android specific commit to use, defaults to HEAD, must be within p4a.branch
  243. #p4a.commit = HEAD
  244. # (str) python-for-android git clone directory (if empty, it will be automatically cloned from github)
  245. #p4a.source_dir =
  246. # (str) The directory in which python-for-android should look for your own build recipes (if any)
  247. #p4a.local_recipes =
  248. # (str) Filename to the hook for p4a
  249. #p4a.hook =
  250. # (str) Bootstrap to use for android builds
  251. # p4a.bootstrap = sdl2
  252. # (int) port number to specify an explicit --port= p4a argument (eg for bootstrap flask)
  253. #p4a.port =
  254. # Control passing the --use-setup-py vs --ignore-setup-py to p4a
  255. # "in the future" --use-setup-py is going to be the default behaviour in p4a, right now it is not
  256. # Setting this to false will pass --ignore-setup-py, true will pass --use-setup-py
  257. # NOTE: this is general setuptools integration, having pyproject.toml is enough, no need to generate
  258. # setup.py if you're using Poetry, but you need to add "toml" to source.include_exts.
  259. #p4a.setup_py = false
  260. # (str) extra command line arguments to pass when invoking pythonforandroid.toolchain
  261. #p4a.extra_args =
  262. #
  263. # iOS specific
  264. #
  265. # (str) Path to a custom kivy-ios folder
  266. #ios.kivy_ios_dir = ../kivy-ios
  267. # Alternately, specify the URL and branch of a git checkout:
  268. ios.kivy_ios_url = https://github.com/kivy/kivy-ios
  269. ios.kivy_ios_branch = master
  270. # Another platform dependency: ios-deploy
  271. # Uncomment to use a custom checkout
  272. #ios.ios_deploy_dir = ../ios_deploy
  273. # Or specify URL and branch
  274. ios.ios_deploy_url = https://github.com/phonegap/ios-deploy
  275. ios.ios_deploy_branch = 1.10.0
  276. # (bool) Whether or not to sign the code
  277. ios.codesign.allowed = false
  278. # (str) Name of the certificate to use for signing the debug version
  279. # Get a list of available identities: buildozer ios list_identities
  280. #ios.codesign.debug = "iPhone Developer: <lastname> <firstname> (<hexstring>)"
  281. # (str) The development team to use for signing the debug version
  282. #ios.codesign.development_team.debug = <hexstring>
  283. # (str) Name of the certificate to use for signing the release version
  284. #ios.codesign.release = %(ios.codesign.debug)s
  285. # (str) The development team to use for signing the release version
  286. #ios.codesign.development_team.release = <hexstring>
  287. # (str) URL pointing to .ipa file to be installed
  288. # This option should be defined along with `display_image_url` and `full_size_image_url` options.
  289. #ios.manifest.app_url =
  290. # (str) URL pointing to an icon (57x57px) to be displayed during download
  291. # This option should be defined along with `app_url` and `full_size_image_url` options.
  292. #ios.manifest.display_image_url =
  293. # (str) URL pointing to a large icon (512x512px) to be used by iTunes
  294. # This option should be defined along with `app_url` and `display_image_url` options.
  295. #ios.manifest.full_size_image_url =
  296. [buildozer]
  297. # (int) Log level (0 = error only, 1 = info, 2 = debug (with command output))
  298. log_level = 2
  299. # (int) Display warning if buildozer is run as root (0 = False, 1 = True)
  300. warn_on_root = 1
  301. # (str) Path to build artifact storage, absolute or relative to spec file
  302. # build_dir = ./.buildozer
  303. # (str) Path to build output (i.e. .apk, .aab, .ipa) storage
  304. # bin_dir = ./bin
  305. # -----------------------------------------------------------------------------
  306. # List as sections
  307. #
  308. # You can define all the "list" as [section:key].
  309. # Each line will be considered as a option to the list.
  310. # Let's take [app] / source.exclude_patterns.
  311. # Instead of doing:
  312. #
  313. #[app]
  314. #source.exclude_patterns = license,data/audio/*.wav,data/images/original/*
  315. #
  316. # This can be translated into:
  317. #
  318. #[app:source.exclude_patterns]
  319. #license
  320. #data/audio/*.wav
  321. #data/images/original/*
  322. #
  323. # -----------------------------------------------------------------------------
  324. # Profiles
  325. #
  326. # You can extend section / key with a profile
  327. # For example, you want to deploy a demo version of your application without
  328. # HD content. You could first change the title to add "(demo)" in the name
  329. # and extend the excluded directories to remove the HD content.
  330. #
  331. #[app@demo]
  332. #title = My Application (demo)
  333. #
  334. #[app:source.exclude_patterns@demo]
  335. #images/hd/*
  336. #
  337. # Then, invoke the command line with the "demo" profile:
  338. #
  339. #buildozer --profile demo android debug